admin@demi4.com

pkg_resources.ContextualVersionConflict: (cryptography 1.7.1 (/usr/lib/python3/dist-packages), Requirement.parse(‘cryptography>=2.2.1’), {‘PyOpenSSL’})

pkg_resources.ContextualVersionConflict

Дуже тупа помилка при роботі з certbot довго думав як виправити та не знайшов кращого шляху ніж видалити та встановити знову потрібну версію

все просто – видяляємо каталог з лібою, об через pip3 не видаляється, та встановулюємо по новому

та й усе 🙂

3 голоса
Позначки:,

Залишити відповідь

Увійти через: 

Ваша e-mail адреса не оприлюднюватиметься. Обов’язкові поля позначені *

Related Post

Let's encrypt wildcard сертифікати

Let’s encrypt wildcard сертифікатиLet’s encrypt wildcard сертифікати

Нещодавно Let’s ecnrypt анонсували вихід APIv2 та можливість замовити woldcard сертифікат для доменів безкоштовно на 3 місяці. 2 голоса Схожі записи: Certbot Let’s encrypt wildcard and CloudFlare cloudflare ERR_SSL_VERSION_OR_CIPHER_MISMATCH vnc