admin@demi4.com

pg_dump on slave – DETAIL: User query might have needed to see row versions that must be removed

pg_dump on slave - DETAIL: User query might have needed to see row versions that must be removed

Налаштовував бекап на slave сервері, та зіткнувся з помилкою, яка призводить до падіння бекап процесу.

Запустив скрипта і тут таке:

Пошукавши в інеті інфо щодо цього повідослення, з’ясувалось таке – що під час створення дампу, slave очикував деякий час завершення транзакції на мастері, не дочекався і припинив процесс.

Вирішилась ситуація додаванням на слейв сервері параметрів у конфіг postgresql.conf

Розмір параметів:

визначається експерементально – з огляду на час виконання максимально довгого запиту у базі.

Після цього перезапутити postgres та можна робити бекап.

0 голосов
Позначки:, ,

Leave a Reply

Увійти через: 

Ваша e-mail адреса не оприлюднюватиметься. Обов’язкові поля позначені *

Related Post

nginx proxy_pass change url

nginx proxy_pass change urlnginx proxy_pass change url

Для проксирования запросов с участием динамических ссылок – необходимо делать реврайт до проксирования (в location). 1 голос Схожі записи: nginx proxy_pass $variable Обрезать IP в nginx $remote_addr nginx ограничение скорости

letsencrypt

Certbot Let’s encrypt wildcard and CloudFlareCertbot Let’s encrypt wildcard and CloudFlare

Зараз дуже круто для пересічних айтішників – не потрібно купувати сертифікати для https, достатньо один раз налаштувати та й усе. 2 голоса Схожі записи: Let’s encrypt wildcard сертифікати Let’s Encrypt

Invalid command ‘Header’

Invalid command ‘Header’, perhaps misspelled or defined by a module not included in the server configurationInvalid command ‘Header’, perhaps misspelled or defined by a module not included in the server configuration

Invalid command ‘Header’, perhaps misspelled or defined by a module not included in the server configuration – такую ошибку можно словить в логах если в апаче не включена поддержка подуля “header”,