Автор: graff

pkg_resources.ContextualVersionConflict

pkg_resources.ContextualVersionConflict: (cryptography 1.7.1 (/usr/lib/python3/dist-packages), Requirement.parse(‘cryptography>=2.2.1’), {‘PyOpenSSL’})pkg_resources.ContextualVersionConflict: (cryptography 1.7.1 (/usr/lib/python3/dist-packages), Requirement.parse(‘cryptography>=2.2.1’), {‘PyOpenSSL’})

Дуже тупа помилка при роботі з certbot довго думав як виправити та не знайшов кращого шляху ніж видалити та встановити знову потрібну версію

set default system python2 or python3 on Debian Linuxset default system python2 or python3 on Debian Linux

Python така штука що іноді допомагає, а іноді дуже дратує, так може статись коли потрібно щоб у системі був python3 as default але зробити це “правильно” потрібно трошки поконфігурити

postfix - відправлення пошти з IP домену

postfix – відправлення пошти з IP доменуpostfix – відправлення пошти з IP домену

Сьогодні стала задача – маємо сервер з двома IP адресами, на цьому сервері декілька доменів, всі домени окрім одного працюють на одному ip, один на окремому. Треба щоб postfix відправляв

Bash спеціальні змінні та спеціальні порівняння

Bash спеціальні змінні та спеціальні порівнянняBash спеціальні змінні та спеціальні порівняння

Мені не часто стає нагода щось написати по роботі, та коли стає задача то завжди забуваєш значення спеціальних змінних у bash або спеціальних порівняннях